Commit c8a591cd by Ruben Rodriguez

Added ubuntu-release-upgrader helper

parent 55509ab9
[View]
# the views will be tried in this order, if one fails to import, the next
# is tried
View=DistUpgradeViewGtk,DistUpgradeViewGtk3,DistUpgradeViewKDE,DistUpgradeViewText
View=DistUpgradeViewGtk3,DistUpgradeViewGtk,DistUpgradeViewKDE,DistUpgradeViewText
#View=DistUpgradeViewNonInteractive
#Depends= python-apt (>= 0.6.0), apt (>= 0.6)
# the views below support upgrades over ssh connection
......@@ -10,20 +10,20 @@ SupportSSH=DistUpgradeViewText,DistUpgradeViewNonInteractive
# Distro contains global information about the upgrade
[Distro]
# the meta-pkgs we support
MetaPkgs=trisquel, trisquel-mini
BaseMetaPkgs=trisquel-base, trisquel-desktop-common, trisquel-gnome-base, trisquel-minimal
MetaPkgs=trisquel-recommended, trisquel-mini-recommended, triskel-recommended, trisquel-sugar-recommended
BaseMetaPkgs=trisquel-minimal, trisquel-base-recommended
Demotions=demoted.cfg
RemoveEssentialOk=sysvinit, sysvutils, belocs-locales-bin
RemovalBlacklistFile=removal_blacklist.cfg
# if those packages were installed, make sure to keep them installed
KeepInstalledPkgs=gnumeric, hpijs
KeepInstalledPkgs=gnumeric, hpijs, xserver-xorg-video-all
KeepInstalledSection=translations
RemoveObsoletes=yes
ForcedObsoletes=ksplash-engine-moodin, powernowd, laptop-mode-tools
ForcedObsoletes=ksplash-engine-moodin, powernowd, laptop-mode-tools, gnome-session-flashback
# hints for for stuff that should be done early
PostUpgradePurge=ltsp-client, ltspfsd, linux-restricted-modules-common
PostUpgradeRemove=casper, libflashsupport, kvm-source, gtk-qt-engine, libparted1.8-12, usplash, printconf, foomatic-db-gutenprint, ebox-printers, kbluetooth, kde-plasmoid-cwp
PostUpgradeUpgrade=brasero
PostUpgradePurge=ltsp-client, ltspfsd
PostUpgradeRemove=libflashsupport, kvm-source, gtk-qt-engine, libparted1.8-12, usplash, printconf, foomatic-db-gutenprint, ebox-printers, kbluetooth, kde-plasmoid-cwp, kdm, xsettings-kde
PostUpgradeUpgrade=brasero,edubuntu-desktop
#PostUpgradeInstall=apt
PostInstallScripts=./trisquel-postinstall.sh
EnableApport=yes
......@@ -34,19 +34,19 @@ BadVersions=blcr-dkms_0.8.2-13
#SlideshowUrl=http://people.canonical.com/~mvo/ubiquity-slideshow-upgrade/slides/
[KernelRemoval]
Version=3.0.0
Version=3.2.0
BaseNames=linux-image,linux-headers,linux-image-debug,linux-backport-modules,linux-header-lbm
Types=386,ec2,generic,rt,server,virtual
# information about the individual meta-pkgs
[trisquel]
KeyDependencies=gdm
KeyDependencies=trisquel-desktop-common-data, unity-greeter, trisquel-session
# those pkgs will be marked remove right after the distUpgrade in the cache
PostUpgradeRemove=casper, xscreensaver, gnome-cups-manager, powermanagement-interface, deskbar-applet, nautilus-cd-burner
ForcedObsoletes=desktop-effects, cups-pdf, policykit-gnome, gnome-mount
PostUpgradeRemove=casper, xscreensaver, gnome-cups-manager, powermanagement-interface, deskbar-applet, nautilus-cd-burner, compiz-core, gdm, gnome-ppp, gwibber, remmina-common
ForcedObsoletes=desktop-effects, cups-pdf, policykit-gnome, gnome-mount, gdm, notification-daemon
[trisquel-mini]
KeyDependencies=trisquel-mini-data lxdm
KeyDependencies=trisquel-mini-data unity-greeter
#Remove previous gnome component from ltrisquel to avoid pulling gnome depends on upgrade (LP: #945215)
PostUpgradeRemove=casper, gnome-bluetooth, gnome-power-manager
......@@ -55,12 +55,13 @@ BackupExt=distUpgrade
LogDir=/var/log/dist-upgrade/
[Sources]
From=brigantia
To=toutatis
From=toutatis
To=belenos
ValidOrigin=Trisquel
ValidMirrors = mirrors.cfg
Components=main
Pockets=security,updates,backports
;AllowThirdParty=False
;[PreRequists]
;Packages=release-upgrader-apt,release-upgrader-dpkg
......@@ -88,4 +89,3 @@ RealReboot=no
DebugBrokenScripts=no
DpkgProgressLog=no
;TerminalTimeout=2400
[View]
# the views will be tried in this order, if one fails to import, the next
# is tried
View=DistUpgradeViewGtk3,DistUpgradeViewGtk,DistUpgradeViewKDE,DistUpgradeViewText
#View=DistUpgradeViewNonInteractive
#Depends= python-apt (>= 0.6.0), apt (>= 0.6)
# the views below support upgrades over ssh connection
SupportSSH=DistUpgradeViewText,DistUpgradeViewNonInteractive
# Distro contains global information about the upgrade
[Distro]
# the meta-pkgs we support
MetaPkgs=trisquel-recommended, trisquel-mini-recommended, triskel-recommended, trisquel-sugar-recommended
BaseMetaPkgs=trisquel-minimal, trisquel-base-recommended
Demotions=demoted.cfg
RemoveEssentialOk=sysvinit, sysvutils, belocs-locales-bin
RemovalBlacklistFile=removal_blacklist.cfg
# if those packages were installed, make sure to keep them installed
KeepInstalledPkgs=gnumeric, hpijs, xserver-xorg-video-all
KeepInstalledSection=translations
RemoveObsoletes=yes
ForcedObsoletes=ksplash-engine-moodin, powernowd, laptop-mode-tools, gnome-session-flashback
# hints for for stuff that should be done early
PostUpgradePurge=ltsp-client, ltspfsd
PostUpgradeRemove=libflashsupport, kvm-source, gtk-qt-engine, libparted1.8-12, usplash, printconf, foomatic-db-gutenprint, ebox-printers, kbluetooth, kde-plasmoid-cwp, kdm, xsettings-kde
PostUpgradeUpgrade=brasero,edubuntu-desktop
#PostUpgradeInstall=apt
PostInstallScripts=./trisquel-postinstall.sh
EnableApport=yes
# this supported blacklisting certain versions to ensure we do not upgrade
# - blcr-dkms fails to build on kernel 2.6.35
BadVersions=blcr-dkms_0.8.2-13
# ubiquity slideshow
#SlideshowUrl=http://people.canonical.com/~mvo/ubiquity-slideshow-upgrade/slides/
[KernelRemoval]
Version=3.2.0
BaseNames=linux-image,linux-headers,linux-image-debug,linux-backport-modules,linux-header-lbm
Types=386,ec2,generic,rt,server,virtual
# information about the individual meta-pkgs
[trisquel]
KeyDependencies=trisquel-desktop-common-data, unity-greeter, trisquel-session
# those pkgs will be marked remove right after the distUpgrade in the cache
PostUpgradeRemove=casper, xscreensaver, gnome-cups-manager, powermanagement-interface, deskbar-applet, nautilus-cd-burner, compiz-core, gdm, gnome-ppp, gwibber, remmina-common
ForcedObsoletes=desktop-effects, cups-pdf, policykit-gnome, gnome-mount, gdm, notification-daemon
[trisquel-mini]
KeyDependencies=trisquel-mini-data unity-greeter
#Remove previous gnome component from ltrisquel to avoid pulling gnome depends on upgrade (LP: #945215)
PostUpgradeRemove=casper, gnome-bluetooth, gnome-power-manager
[Files]
BackupExt=distUpgrade
LogDir=/var/log/dist-upgrade/
[Sources]
From=toutatis
To=belenos
ValidOrigin=Trisquel
ValidMirrors = mirrors.cfg
Components=main
Pockets=security,updates,backports
;AllowThirdParty=False
;[PreRequists]
;Packages=release-upgrader-apt,release-upgrader-dpkg
;SourcesList=prerequists-sources.list
;SourcesList-ia64=prerequists-sources.ports.list
;SourcesList-hppa=prerequists-sources.ports.list
[Aufs]
; this is a xor option, either full or chroot overlay
;EnableFullOverlay=yes
;EnableChrootOverlay=yes
; sync changes from the chroot back to the real system
;EnableChrootRsync=yes
; what chroot dir to use
;ChrootDir=/tmp/upgrade-chroot
; the RW dir to use (either for full overlay or chroot overlay)
;RWDir=/tmp/upgrade-rw
[Network]
MaxRetries=3
[NonInteractive]
ForceOverwrite=yes
RealReboot=no
DebugBrokenScripts=no
DpkgProgressLog=no
;TerminalTimeout=2400
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment